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Introduction and Summary 
 

Typical biometric studies of organisms are based on measurements made on reference 
points or landmarks.  A great deal of effort can go into defining and measuring landmarks, 
with the hope that they represent the essential morphological characters of the organism.  
This document describes a detailed methodology using heads-up digitizing from photographs 
and ArcGIS® 10 software for capturing significantly more information with only minor 
increased effort.  The method is demonstrated by morphometric analysis of sand dollar 



2 
 

echinoids.  Rather than collect the coordinates of individual landmarks, the sutures between 
all skeletal plates are digitized, constrained by standard topological rules, and converted into 
polygons.  Although the data are digitized from 2-dimensional photographs, full 3-
dimensional models can be generated based on a few key measurements and straight-forward 
geometric transformations.  The data are stored in geodatabase format (which can include the 
photography as embedded raster datasets, if desired) and can be exported in a variety of 
common formats, including GIS shapefiles and Excel® tables.  Plate number, centroid, 
perimeter, area, and juxtaposition are automatically calculated.  The method can also be used 
to capture data regarding ornamentation (tubercle size and location) and associated 
characters. 

 
It is assumed for these instructions that the user has basic knowledge of ArcGIS 10 or 

access to a good tutorial guide such as that by Ormsby, et al. (2010), Getting to Know ArcGIS 
10. 

 
Data 
 

The basic starting data set consists of photographs of the specimen to be modeled.  High-
quality photographs represented by .tiff format digital images work well.  These files can be 
stored as separate images, or embedded in the geodatabase you create. 

 
1.  Create a Personal Geodatabase 
 

1.1  Create a Geodatabase, Feature Datasets, and Feature Classes 
 

1.  Open ArcCatalog. 
 
2. Navigate in the Catalog Tree to the directory where you want to build the 

geodatabase. 
 
3.  Right click on the directory name and select New > Personal Geodatabase.  

Rename the database to reflect the project you are working on. 
 
4.  Right click on the new geodatabase and create a new Feature Dataset, giving it a 

name to reflect the data it will contain.  The coordinate system will be 
Unknown.  The default X-Y Tolerance (0.001 units) is probably fine for most 
applications. 

 
5.   Right click on the new Feature Dataset and create a new Feature Class, again 

using an applicable name.  Choose a Line Features type.  Do not include M or 
Z value coordinates.  Do not add any fields. 

 
6.  Create as many feature datasets as needed, each with an initial line feature class. 
 
7.  Close ArcCatalog when done. 
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1.2  Digitize Features 
 

1.  Open ArcMap. 
 
2.  Open a blank map document. 
 
3.  Add an image to digitize.  You generally do not need to build pyramids. 
 
4.  Add the feature class you want to digitize into and select it (highlight it) 
 
4.   Open the Editor toolbar (from Customize > Toolbars). 
 
5.  Select Start Editing from the drop down menu.  Choose the feature class to edit, 

and select the Line drawing tool. 
 
6.  Using the line drawing tool, digitize line features from the image.  Before 

digitizing, set the snapping options for a reasonable snapping distance – 
usually 5 to 10 pixels is a good distance.  Take care when digitizing to always 
snap line segments together.  This will save time when cleaning up topology. 

 
7.  Save your edits regularly.  When done, Stop Editing and save your edits. 
 
8.  The editing toolbar gives access to a number of useful editing tools if you need to 

go back and modify the digitized lines.  Most useful are tools to edit 
individual vertices and to split lines. 

 
1.3  Create Topology 

 
1.  Open ArcCatalog (you can do this from ArcMap). 
 
2.  Right click on the Feature Dataset you want to create topology for and select New 

Topology. 
 
3.  The Topology Wizard will lead you through the initial steps. 
 
4.  When you get to the dialog for rule specification, add the following rules:  Must 

not overlap, Must not intersect, Must not have dangles, Must not self-overlap, 
and Must not self-intersect.  Be sure to specify the feature class target for the 
rules.  You can save the rule set to use with other features. 

 
5.  Validate the feature class.  If there are any topological errors displayed they will 

need to be fixed before polygons can be built. 
 
If topological errors need to be repaired, follow steps 6-8. 
 
6.  In the editor toolbar, start editing the line feature class. 
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7.  Open the Topology tool bar.  Select the topology that corresponds to the line 

feature class. Use the Topology tools to fix and validate the features as 
necessary. 

 
8.  When done you can close the Topology toolbar. 
 

2.  Post-Process Feature Classes 
 

If digitizing two sides of a fossil from photographs, the two viewpoints are opposed.  
One is from the top, the other from the bottom.  When layering the features digitized from 
these photographs, it is necessary to choose one viewpoint (preferably from the top), and 
mirror the features digitized from the other viewpoint.  In almost every case, the two 
digitized feature class will not exactly overlay each other (it is nearly impossible to digitize 
from two separate photographs and get perfect correspondence).  This can be corrected using 
affine spatial adjustment. 
 

2.1 Mirror a Feature Class 

1.  Right click on the line feature class, select Data > Export to Geodatabase, and 
export the line features to a new feature class.  Add the feature class to the 
Table of Contents. 
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2.  Open the Editor toolbar and begin editing the new feature class. 
 
3. Select the Mirror Feature Tool. 

 
4.  Select all of the line features.  Try to center the mirror line as close to the center of 

the image as possible.  This will simplify later adjustments. 
5. After mirroring the features, delete the selected set (keeping the mirrored lines). 
 
6.  Save the features. 

 

2.2 Adjust Feature Class Misalignments 

1.  Open the Spatial Adjustment Toolbar.  If you closed the Editor, reopen it and start 
editing the feature class that you will be adjusting (the mirror set from the 
earlier procedure). 

 
2.  Display the feature class you want to adjust the features to. 
 
3.  Using the tools on the Spatial Adjustment toolbar, create a set of links indicating 

adjustment points.  The more links the better the overall adjustment.  Try to 
scatter the links over the entire feature class. 

 
4. Use the Affine adjustment method to adjust the features. 
 
5.  Save the adjusted feature class and exit the editor. 
 

3. Create Polygons 
 
There are two methods for creating polygons from line features, depending on the level of 
license the user has available. 
 

3.1 Create Polygons with ArcInfo license 
 

1.  In ArcToolbox > Data Management Tools > Features select the Feature to Polygon 
tool. 

 
2.  Follow the Dialog to create a polygon feature class from the line features. 
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3.2 Create Polygons without ArcInfo license (ArcView or ArcEditor incense level) 
 

You cannot create polygons from within ArcMap if you only have an 
ArcView or ArcEditor license.  You must create them from ArcCatalog.  In addition, 
this requires that you have Service Pack 4 for ArcGIS 10 installed.  The following 
instructions are copied from the ESRI support page Article ID 38276 
(http://support.esri.com/en/knowledgebase/techarticles/detail/38276) 
 
1.  Start ArcCatalog. 
 
2.  Click the Customize menu and click Customize Mode. On the Toolbars tab, check 

the box next to Context Menus. Notice a toolbar opens that contains a list of 
context menus. 

 
3.  Click the Commands tab. In the 'Show commands containing' box, type Polygon 

Feature Class From Lines. The command is in the Topology category.  
 
4.  On the Context Menus toolbar, click the Context Menus menu to see a list of the 

available menus.   Scroll down and find the Feature Dataset Context Menu. 
Click it, and click New to open the sub-menu.  
 

5.  With the Customize dialog box still open, drag the Polygon Feature Class From 
Lines icon from the Commands tab and drop it onto the Feature Dataset 
Context Menu > New menu. Close the Customize dialog box when done.  
 

6.  In the Catalog tree, browse to the feature dataset where the new polygon feature 
class is going to be created. Right-click it, point to New, and click Polygon 
Feature Class From Lines.  
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7.  Type a name for the new polygon feature class, set the cluster tolerance, and check 
one or more line feature classes to use when creating the new polygons.  
 
8.  Click OK.  

 
3.3 Add Attributes 
 

1.  Right click on the feature class and open the attribute table. 
 
2.  Choose the Add Field … option from the drop down menu. 

 
 
3.  Add fields as needed.  Define the type and size of each field. 
 
4.  Open the Editor and start editing the feature class to which you want to add 

attributes. 
 
5.  In edit mode the attribute table and the graphic polygons are linked, you can 

choose either and add new values to the fields you created above. 
 

4. Convert to 3D 

4.1 Create and Extract Polygon Centroids 

1. Open ArcMap. 
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2. Right click on the polygon feature class and open the attribute table. 
 

 
3.  Choose the Add Field … option from the drop down menu.  Add X, Y, and Z 

fields (make them Float types). 
 
4.  Right click on the X or Y field and choose Calculate Geometry, and select X (or 

Y) Coordinate of Centroid.  Do this for the X and Y fields. 
 

 
5.  Select any centroids where the z-value is known by measurement or estimate and 

set the Z to that value.  Most of the Z values will remain 0. 
 
5.  Export the attribute table to a new DBF table.  Add the table to the project. 
 
6.  Click File > Add Data  > Add XY Data and select the dbf table just created. 
 
7.  Export the new point event theme to a new feature class in the geodatabase.  This 

feature class represents the centroids of the polygons. 
 

4.2 Fit a Surface to Selected Z-values and Interpolate Centroid Z-values 

The following example uses MATLAB to interpolate z-values for all of the 
centroid points based on the z-values of the margin centroids and the z-value of the center 
centroid.  This is a very specific example, but the general process can be used for any 
case where a few z-values are known and a model can be used to interpolate the rest. 

 
1.  Either export the centroid dbf table to text from ArcGIS or convert it to text using 

an external program (e.g., Excel). 
 
2.  Import the text file to the variable data in MATLAB.  Data will be a Nx3 array 

with the x-values in the first column, y-values in the second column, and z-
values in the third column. 
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3.  The example MATLAB script will create a new text file of interpolated z-values 

for all of the centroid x-y coordinates based on a linear interpolation. 
 

centroids = data; 
zpts = data(find(data(:,3)==1),:); 
zpts(:,3) = 0.1; 
zpts(11,3) = 1; 
  
minx = min(centroids(:,1)); 
maxx = max(centroids(:,1)); 
miny = min(centroids(:,2)); 
maxy = max(centroids(:,2)); 
  
[X,Y] = meshgrid(minx:.1:maxx,miny:.1:maxy); 
Z = griddata(zpts(:,1),zpts(:,2),zpts(:,3),X,Y); 
mesh(X,Y,Z) 
  
hold 
plot3(zpts(:,1),zpts(:,2),zpts(:,3),'.') 
ZI = interp2(X,Y,Z,centroids(:,1),centroids(:,2)); 
plot3(centroids(:,1),centroids(:,2),ZI,'.') 
axis equal; 
hold off 
  
outmat = horzcat(centroids(:,1),centroids(:,2),ZI); 
outmat(find(isnan(outmat(:,3))),3)= .1; 
  
dlmwrite('interp_z.txt',outmat,'newline','pc'); 

 

4.3 Convert 2D to 3D Feature Class 

1.  Click File > Add Data  > Add XY Data and select the text file of interpolated 
centroids.  Specify the Z field as well as the XY fields.  This will create a 3D 
event theme of the centroids. 

 
2.  Export the event theme to a new point feature class. 
 
3.  In ArcTools > 3D Analyst Tools > TIN Management chose Create TIN.  Use the 

dialog to create a TIN from the new feature class. 
 
4.  In ArcTools > 3D Analysts Tools > Terrain and TIN surface choose Interpolate 

Polygon to Multipatch.  Use the dialog to create a 3D multipatch feature of the 
polygons. 

 
5.  Alternatively, use the TIN surface to drape the polygon feature over in ArcScene 

for 3D viewing.  At this point full 3D information is available for further 
analysis.  

 


